Howto / Ubuntu
addthis
Configurare il modem Momodesign MD-@ della H3G con Ubuntu Gutsy 7.10
Author: Tafaz
Visits: 14485
Date: 29.02.2008

Lo scopo di questa guida è di installare e configurare il modem ADSM HSDPA Momodesign MD-@ della Tre su Ubuntu.

 

 

La versione di Ubuntu che uso e su cui è stato testato il funzionamento sotto descritto è Ubuntu Gutsy Gibbon 7.10, se avete modo di testarlo su altre versioni lasciate un commento.

In internet ci sono vari tutorial che spiegano come far funzionare questo modem con due differenti metodi, quello che useremo sarà airprime, in quanto se usassimo usbserial i download sarebbero limitati a 60KB/s per un limite del driver, inoltre il modulo airprime ci permette, dopo una breve configurazione iniziale, di caricare il modulo durante il boot e quindi questa procedura va fatta solo la prima volta.

Per permettere al modulo airprime di riconoscere il nostro modem bisogna modificare il file sorgente airprime.c inserendovi l'id della nostro modem usb.

Per ottenere l'id colleghiamo il modem ad una porta USB, assicurandoci che la levetta sul lato sia in posizione di modem e non di usb key, e da una shell digitiamo lsusb, l'output del programma sarà qualcosa di simile

tafaz@Nefertum:/usr/src# lsusb
Bus 006 Device 001: ID 0000:0000
Bus 006 Device 002: ID 0000:0000 
Bus 007 Device 003: ID 0000:0000 
Bus 004 Device 004: ID 05c6:6000 Qualcomm, Inc.


il modem ha la descrizione Qualcomm, Inc. e l'id dev'essere 05c6:6000

Verifichiamo la versione del kernel nel seguente modo

tafaz@Nefertum:~# uname -r
2.6.22-14-generic


A questo punto scarichiamo i sorgenti del kernel (il 2.6.22 nel mio caso) e un po di pacchetti per compilare i sorgenti con il seguente comando

tafaz@Nefertum:~$ sudo apt-get install make gcc kernel-package libncurses5-dev linux-source-2.6.22
[sudo] password for tafaz:
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso      
Reading state information... Fatto              
make è già alla versione più recente.
gcc è già alla versione più recente.
Pacchetti suggeriti:
  linux-source kernel-source libdb3-dev libncurses-dev docbook-utils
  libqt3-dev
I seguenti pacchetti NUOVI (NEW) saranno installati:
  kernel-package libncurses5-dev linux-source-2.6.22
0 aggiornati, 3 installati, 0 da rimuovere e 0 non aggiornati.
È necessario prendere 1967kB/47,3MB di archivi.
Dopo l'estrazione, verranno occupati 54,0MB di spazio su disco.
Get:1 http://it.archive.ubuntu.com gutsy/main kernel-package 11.001 [510kB]
Get:2 http://it.archive.ubuntu.com gutsy/main libncurses5-dev 5.6+20070716-1ubuntu3 [1456kB]
Scaricato 1967kB in 3s (572kB/s)                                  
Selezionato il pacchetto kernel-package, che non lo era.
(Lettura del database ... 114130 file e directory attualmente installati.)
Spacchetto kernel-package (da .../kernel-package_11.001_all.deb) ...
Selezionato il pacchetto libncurses5-dev, che non lo era.
Spacchetto libncurses5-dev (da .../libncurses5-dev_5.6+20070716-1ubuntu3_i386.deb) ...
Selezionato il pacchetto linux-source-2.6.22, che non lo era.
Spacchetto linux-source-2.6.22 (da .../linux-source-2.6.22_2.6.22-14.52_all.deb) ...
Configuro kernel-package (11.001) ...
Configuro libncurses5-dev (5.6+20070716-1ubuntu3) ...
Configuro linux-source-2.6.22 (2.6.22-14.52) ...
tafaz@Nefertum:~$




Page 1 of 4 >>


Se vuoi discutere con noi su questo articolo o comunque vuoi porci delle domande usa il nostro Forum

COMMENTI

Aggiungi un commento! +
(I commenti verranno moderati prima della pubblicazione)



Top